dev-python/graphene-django: Dep fix
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
This commit is contained in:
parent
db5d99a7b9
commit
15193279a2
|
@ -0,0 +1,12 @@
|
||||||
|
--- a/setup.py 2021-09-20 18:33:44.985238371 +0200
|
||||||
|
+++ b/setup.py 2021-09-20 18:32:49.889432686 +0200
|
||||||
|
@@ -68,8 +68,7 @@
|
||||||
|
"promise>=2.1",
|
||||||
|
"text-unidecode",
|
||||||
|
],
|
||||||
|
- setup_requires=["pytest-runner"],
|
||||||
|
- tests_require=tests_require,
|
||||||
|
+ tests_require=tests_require + ["pytest-runner"],
|
||||||
|
rest_framework_require=rest_framework_require,
|
||||||
|
extras_require={
|
||||||
|
"test": tests_require,
|
|
@ -3,7 +3,7 @@
|
||||||
|
|
||||||
EAPI=8
|
EAPI=8
|
||||||
|
|
||||||
PYTHON_COMPAT=( python3_{8..10} )
|
PYTHON_COMPAT=( python3_{8..9} )
|
||||||
inherit distutils-r1
|
inherit distutils-r1
|
||||||
|
|
||||||
DESCRIPTION="Graphene Django integration"
|
DESCRIPTION="Graphene Django integration"
|
||||||
|
@ -14,6 +14,19 @@ LICENSE="MIT"
|
||||||
SLOT="0"
|
SLOT="0"
|
||||||
KEYWORDS="~amd64"
|
KEYWORDS="~amd64"
|
||||||
|
|
||||||
DEPEND=">=dev-python/djangorestframework-3.6.3[${PYTHON_USEDEP}]"
|
DEPEND="
|
||||||
|
<dev-python/graphene-4
|
||||||
|
<dev-python/graphql-core-4
|
||||||
|
>=dev-python/django-2.2[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/djangorestframework-3.6.3[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/graphene-3.0.0_beta5[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/graphql-core-3.1.0[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/promise-2.1[${PYTHON_USEDEP}]
|
||||||
|
dev-python/text-unidecode[${PYTHON_USEDEP}]
|
||||||
|
"
|
||||||
RDEPEND="${DEPEND}"
|
RDEPEND="${DEPEND}"
|
||||||
BDEPEND=""
|
BDEPEND=""
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/${P}-pytest-runner.patch"
|
||||||
|
)
|
||||||
|
|
Loading…
Reference in a new issue