net-dns/flamethrower: new package, add 0.11.0

This commit is contained in:
Alarig Le Lay 2023-03-27 13:33:42 +02:00
parent 597d18bef5
commit f01e6f8571
Signed by: alarig
GPG Key ID: 7AFE62C6DF8BCDEC
5 changed files with 107 additions and 0 deletions

View File

@ -0,0 +1 @@
DIST flamethrower-0.11.0.tar.gz 322950 BLAKE2B 4fc3ae4b14605d1cb2b5ebae9dfeab959bcaceb410f838f1927e6ae3ea4bfd3aa62151947c9dbeb331252d000d0450a4a19c1ea2e7a7f353c28d5b657f91f954 SHA512 20722159a2310ec7c6b20f9b8ea26376eb25dbc78df21a4aac6400c6720c60e82c4c42c3bc3f24e6aa1fcc11024152b542e0961bdb2ad7e9164d6da40e4f602a

View File

@ -0,0 +1,26 @@
--- a/CMakeLists.txt 2023-03-27 12:46:05.379211976 +0200
+++ b/CMakeLists.txt 2023-03-27 12:48:51.953334842 +0200
@@ -143,23 +143,6 @@
PRIVATE ${LIBUV_LIBRARIES}
)
-add_executable(tests
- tests/main.cpp
- )
-
-target_include_directories(tests SYSTEM
- PRIVATE "${CMAKE_SOURCE_DIR}/3rd/catch"
- )
-
-target_include_directories(tests
- PRIVATE "${CMAKE_SOURCE_DIR}/tests"
- PRIVATE "${CMAKE_SOURCE_DIR}/flame"
- )
-
-target_link_libraries(tests
- PRIVATE flamecore
- )
-
install(TARGETS flame flamecore
RUNTIME DESTINATION bin
LIBRARY DESTINATION lib${LIB_SUFFIX}

View File

@ -0,0 +1,27 @@
From 5056602eb10316f4f1791ec5a7918e1ff40fe7fe Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
Date: Fri, 4 Feb 2022 19:07:02 +0100
Subject: [PATCH] Compile under gcc 12.0.0 (#88)
Add missing includes to query.cpp. It does not compile anymore on gcc 12
without it.
---
flame/query.cpp | 2 ++
1 file changed, 2 insertions(+)
diff --git a/flame/query.cpp b/flame/query.cpp
index 4f7ef21..fdd5f73 100644
--- a/flame/query.cpp
+++ b/flame/query.cpp
@@ -5,9 +5,11 @@
#include <algorithm>
#include <cctype>
#include <climits>
+#include <cstring>
#include <fstream>
#include <iomanip>
#include <iostream>
+#include <iterator>
#include <regex>
#include <sstream>
#include <stdexcept>

View File

@ -0,0 +1,42 @@
# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="DNS performance and functional testing utility"
HOMEPAGE="https://github.com/DNS-OARC/flamethrower"
SRC_URI="https://github.com/DNS-OARC/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doh"
DEPEND="
>=dev-libs/libuv-1.30.0
>=net-libs/ldns-1.7.0
doh? ( net-libs/nghttp2 )
"
RDEPEND="${DEPEND}"
BDEPEND=""
PATCHES=(
"${FILESDIR}/${P}-gcc12.patch"
"${FILESDIR}/${P}-cmakelist.patch"
)
src_prepare() {
rm 3rd/catch/catch2/catch.hpp
rm tests/main.cpp
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DDOH_ENABLE="$(usex doh)"
)
cmake_src_configure
}

View File

@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<name>Alarig Le Lay</name>
<email>alarig@swordarmor.fr</email>
</maintainer>
<use>
<flag name="doh">Build DNS-over-HTTPS support</flag>
</use>
</pkgmetadata>