net-misc/bird: rsync from ::gentoo
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
This commit is contained in:
parent
181eb80716
commit
e2f647cdcf
40
net-misc/bird/bird-2.0.7.ebuild
Normal file
40
net-misc/bird/bird-2.0.7.ebuild
Normal file
|
@ -0,0 +1,40 @@
|
|||
# Copyright 1999-2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 & IPv6"
|
||||
HOMEPAGE="http://bird.network.cz"
|
||||
SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
|
||||
LICENSE="GPL-2"
|
||||
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm64 ~x86 ~x64-macos"
|
||||
IUSE="+client debug"
|
||||
|
||||
RDEPEND="client? ( sys-libs/ncurses )
|
||||
client? ( sys-libs/readline )"
|
||||
DEPEND="sys-devel/flex
|
||||
sys-devel/bison
|
||||
sys-devel/m4"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-gcc10.patch"
|
||||
)
|
||||
|
||||
src_configure() {
|
||||
econf \
|
||||
--localstatedir="${EPREFIX}/var" \
|
||||
$(use_enable client) \
|
||||
$(use_enable debug)
|
||||
}
|
||||
|
||||
src_install() {
|
||||
if use client; then
|
||||
dobin birdc
|
||||
fi
|
||||
dobin birdcl
|
||||
dosbin bird
|
||||
newinitd "${FILESDIR}/initd-${PN}-2" bird
|
||||
dodoc doc/bird.conf.example
|
||||
}
|
|
@ -22,9 +22,11 @@ RDEPEND="
|
|||
acct-user/bird
|
||||
)
|
||||
libssh? ( net-libs/libssh:= )"
|
||||
BDEPEND="sys-devel/flex
|
||||
BDEPEND="
|
||||
sys-devel/bison
|
||||
sys-devel/m4"
|
||||
sys-devel/flex
|
||||
sys-devel/m4
|
||||
"
|
||||
|
||||
FILECAPS=(
|
||||
CAP_NET_ADMIN usr/sbin/bird
|
||||
|
|
12
net-misc/bird/files/bird-2.0.7-gcc10.patch
Normal file
12
net-misc/bird/files/bird-2.0.7-gcc10.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -ruN bird-2.0.7.orig/nest/route.h bird-2.0.7/nest/route.h
|
||||
--- bird-2.0.7.orig/nest/route.h 2019-10-16 13:45:52.000000000 +0300
|
||||
+++ bird-2.0.7/nest/route.h 2020-11-01 02:59:41.199775491 +0200
|
||||
@@ -458,7 +458,7 @@
|
||||
protocol-specific metric is availabe */
|
||||
|
||||
|
||||
-const char * rta_dest_names[RTD_MAX];
|
||||
+extern const char * rta_dest_names[RTD_MAX];
|
||||
|
||||
static inline const char *rta_dest_name(uint n)
|
||||
{ return (n < RTD_MAX) ? rta_dest_names[n] : "???"; }
|
2
net-misc/bird/files/initd-bird-2
Executable file → Normal file
2
net-misc/bird/files/initd-bird-2
Executable file → Normal file
|
@ -1,5 +1,5 @@
|
|||
#!/sbin/openrc-run
|
||||
# Copyright 1999-2020 Gentoo Authors
|
||||
# Copyright 1999-2021 Gentoo Authors
|
||||
# Copyright 2019 Alarig Le Lay <alarig@grifon.fr>
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
|
|
|
@ -5,6 +5,14 @@
|
|||
<email>chainsaw@gentoo.org</email>
|
||||
<name>Tony Vroon</name>
|
||||
</maintainer>
|
||||
<maintainer type="project" proxied="proxy">
|
||||
<email>proxy-maint@gentoo.org</email>
|
||||
<name>Proxy Maintainers</name>
|
||||
</maintainer>
|
||||
<maintainer type="person">
|
||||
<name>Alarig Le Lay</name>
|
||||
<email>alarig@swordarmor.fr</email>
|
||||
</maintainer>
|
||||
<use>
|
||||
<flag name="client">Build the ncurses/readline full featured CLI</flag>
|
||||
<flag name="libssh">
|
||||
|
|
Loading…
Reference in a new issue