dev-libs/libcli: New ebuild
This commit is contained in:
parent
086a73206e
commit
b69d8747b9
1
dev-libs/libcli/Manifest
Normal file
1
dev-libs/libcli/Manifest
Normal file
|
@ -0,0 +1 @@
|
|||
DIST libcli-1.10.2.tar.gz 51365 BLAKE2B 9aca9736e7ccb46c54c709861a89eca2267cf18779c0a7ab958380d272dd72ecd917aa594d3195430d032251df7eda54d4a5b386fd27a39bfd54bdff48aeae92 SHA512 f09817683d298da0b6c71253f8560b76b6a706589804a1c6afe87ce8ae37b8b3430b15380b0807cb805de0fd87753f95bbc1c174ea1c7e561fcff56f0f55c960
|
30
dev-libs/libcli/files/libcli-Makefile.patch
Normal file
30
dev-libs/libcli/files/libcli-Makefile.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- a/libcli-1.10.2/Makefile 2020-02-26 21:30:48.655822684 +0100
|
||||
+++ b/libcli-1.10.2/Makefile 2020-02-26 21:30:59.877871306 +0100
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
UNAME = $(shell sh -c 'uname -s 2>/dev/null || echo not')
|
||||
DESTDIR =
|
||||
-PREFIX = /usr/local
|
||||
+PREFIX = /usr
|
||||
|
||||
MAJOR = 1
|
||||
MINOR = 10
|
||||
@@ -64,14 +64,14 @@
|
||||
rm -f *.o $(LIB)* $(LIB_STATIC) clitest libcli-$(MAJOR).$(MINOR).$(REVISION).tar.gz
|
||||
|
||||
install: $(TARGET_LIBS)
|
||||
- install -d $(DESTDIR)$(PREFIX)/include $(DESTDIR)$(PREFIX)/lib
|
||||
+ install -d $(DESTDIR)$(PREFIX)/include $(DESTDIR)$(PREFIX)/lib64
|
||||
install -m 0644 libcli.h $(DESTDIR)$(PREFIX)/include
|
||||
ifeq (1,$(STATIC_LIB))
|
||||
- install -m 0644 $(LIB_STATIC) $(DESTDIR)$(PREFIX)/lib
|
||||
+ install -m 0644 $(LIB_STATIC) $(DESTDIR)$(PREFIX)/lib64
|
||||
endif
|
||||
ifeq (1,$(DYNAMIC_LIB))
|
||||
- install -m 0755 $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(DESTDIR)$(PREFIX)/lib
|
||||
- cd $(DESTDIR)$(PREFIX)/lib && \
|
||||
+ install -m 0755 $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(DESTDIR)$(PREFIX)/lib64
|
||||
+ cd $(DESTDIR)$(PREFIX)/lib64 && \
|
||||
ln -fs $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR) && \
|
||||
ln -fs $(LIB).$(MAJOR).$(MINOR) $(LIB)
|
||||
endif
|
24
dev-libs/libcli/libcli-1.10.2.ebuild
Normal file
24
dev-libs/libcli/libcli-1.10.2.ebuild
Normal file
|
@ -0,0 +1,24 @@
|
|||
# Copyright 2020 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit eutils
|
||||
|
||||
DESCRIPTION="Shared C library to include Cisco-like CLI into other software"
|
||||
HOMEPAGE="https://dparrish.com/pages/libcli"
|
||||
SRC_URI="https://github.com/dparrish/${PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="LGPL-2.1"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
DEPEND=""
|
||||
RDEPEND="${DEPEND}"
|
||||
BDEPEND=""
|
||||
|
||||
src_prepare() {
|
||||
eapply -p2 "${FILESDIR}/${PN}-Makefile.patch"
|
||||
eapply_user
|
||||
}
|
12
dev-libs/libcli/metadata.xml
Normal file
12
dev-libs/libcli/metadata.xml
Normal file
|
@ -0,0 +1,12 @@
|
|||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>alarig@swordarmor.fr</email>
|
||||
<name>Alarig Le Lay</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>proxy-maint@gentoo.org</email>
|
||||
<name>Proxy Maintainers</name>
|
||||
</maintainer>
|
||||
</pkgmetadata>
|
Loading…
Reference in a new issue