net-misc/youtube-dl: Including patch for https://github.com/ytdl-org/youtube-dl/pull/16432
This commit is contained in:
parent
936f61ef3b
commit
898196b48f
1
net-misc/youtube-dl/Manifest
Normal file
1
net-misc/youtube-dl/Manifest
Normal file
|
@ -0,0 +1 @@
|
|||
DIST youtube-dl-2020.02.16.tar.gz 3161956 BLAKE2B 36cd189b162d98f986d669c4439070efbf344aa05f821b9e35a58fcef8db839ad0e079836e7a84cd17b04afdb113559695ad500f4b0183c7dcefa1694bdccf62 SHA512 1164ad9f875d67844ddc7bf8214bcc06cb384d7f2a5661c1f419f2ce5950b1cfcbf90c558e143b76948d9d7cf57cf3843c8d6392fc6ef77f89319375610f01a2
|
16
net-misc/youtube-dl/files/nrk.patch
Normal file
16
net-misc/youtube-dl/files/nrk.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
diff --git a/youtube_dl/extractor/nrk.py b/youtube_dl/extractor/nrk.py
|
||||
index 94115534b..318a45551 100644
|
||||
--- a/youtube_dl/extractor/nrk.py
|
||||
+++ b/youtube_dl/extractor/nrk.py
|
||||
@@ -75,8 +75,9 @@ class NRKBaseIE(InfoExtractor):
|
||||
entry_id, entry_title = video_id_and_title(num)
|
||||
duration = parse_duration(asset.get('duration'))
|
||||
subtitles = {}
|
||||
- for subtitle in ('webVtt', 'timedText'):
|
||||
- subtitle_url = asset.get('%sSubtitlesUrl' % subtitle)
|
||||
+ subtitle_base = asset.get('timedTextSubtitlesUrl')
|
||||
+ for subtitle in ('ttml', 'vtt'):
|
||||
+ subtitle_url = re.sub(r"ttml$", subtitle, subtitle_base)
|
||||
if subtitle_url:
|
||||
subtitles.setdefault('no', []).append({
|
||||
'url': compat_urllib_parse_unquote(subtitle_url)
|
7
net-misc/youtube-dl/metadata.xml
Normal file
7
net-misc/youtube-dl/metadata.xml
Normal file
|
@ -0,0 +1,7 @@
|
|||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>jer@gentoo.org</email>
|
||||
</maintainer>
|
||||
</pkgmetadata>
|
83
net-misc/youtube-dl/youtube-dl-2020.02.16-r1.ebuild
Normal file
83
net-misc/youtube-dl/youtube-dl-2020.02.16-r1.ebuild
Normal file
|
@ -0,0 +1,83 @@
|
|||
# Copyright 1999-2020 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
PYTHON_COMPAT=(python3_{6,7,8})
|
||||
inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
|
||||
|
||||
DESCRIPTION="Download videos from YouTube.com (and more sites...)"
|
||||
HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
|
||||
SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
|
||||
LICENSE="public-domain"
|
||||
|
||||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
|
||||
SLOT="0"
|
||||
IUSE="test"
|
||||
RESTRICT="!test? ( test )"
|
||||
RDEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
|| (
|
||||
dev-python/pycryptodome[${PYTHON_USEDEP}]
|
||||
dev-python/pycrypto[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
DEPEND="
|
||||
${RDEPEND}
|
||||
test? (
|
||||
dev-python/nose[${PYTHON_USEDEP}]
|
||||
dev-python/flake8[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
S=${WORKDIR}/${PN}
|
||||
|
||||
src_prepare() {
|
||||
eapply "${FILESDIR}/nrk.patch"
|
||||
eapply_user
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
distutils-r1_src_compile
|
||||
}
|
||||
|
||||
python_test() {
|
||||
emake offlinetest
|
||||
}
|
||||
|
||||
python_install_all() {
|
||||
dodoc README.txt
|
||||
doman ${PN}.1
|
||||
|
||||
newbashcomp ${PN}.bash-completion ${PN}
|
||||
|
||||
insinto /usr/share/zsh/site-functions
|
||||
newins ${PN}.zsh _${PN}
|
||||
|
||||
insinto /usr/share/fish/vendor_completions.d
|
||||
doins ${PN}.fish
|
||||
|
||||
distutils-r1_python_install_all
|
||||
|
||||
rm -r "${ED}"/usr/etc || die
|
||||
rm -r "${ED}"/usr/share/doc/youtube_dl || die
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
|
||||
elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
|
||||
elog
|
||||
elog "${PN} works fine on its own on most sites. However, if you want"
|
||||
elog "to convert video/audio, you'll need avconf (media-video/libav) or"
|
||||
elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
|
||||
elog "videos can be retrieved in a higher quality format without sound."
|
||||
elog "${PN} will detect whether avconv/ffmpeg is present and"
|
||||
elog "automatically pick the best option."
|
||||
elog
|
||||
elog "Videos or video formats streamed via RTMP protocol can only be"
|
||||
elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
|
||||
elog
|
||||
elog "Downloading MMS and RTSP videos requires either mplayer"
|
||||
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
|
||||
elog
|
||||
elog "If you want ${PN} to embed thumbnails from the metadata into the"
|
||||
elog "resulting MP4 files, consider installing media-video/atomicparsley"
|
||||
}
|
83
net-misc/youtube-dl/youtube-dl-99999999.ebuild
Normal file
83
net-misc/youtube-dl/youtube-dl-99999999.ebuild
Normal file
|
@ -0,0 +1,83 @@
|
|||
# Copyright 1999-2020 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
PYTHON_COMPAT=(python3_{6,7,8})
|
||||
inherit bash-completion-r1 distutils-r1 git-r3 readme.gentoo-r1
|
||||
|
||||
DESCRIPTION="Download videos from YouTube.com (and more sites...)"
|
||||
HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
|
||||
EGIT_REPO_URI="https://github.com/ytdl-org/youtube-dl/"
|
||||
LICENSE="public-domain"
|
||||
|
||||
KEYWORDS=""
|
||||
SLOT="0"
|
||||
IUSE="test"
|
||||
RESTRICT="!test? ( test )"
|
||||
RDEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
|| (
|
||||
dev-python/pycryptodome[${PYTHON_USEDEP}]
|
||||
dev-python/pycrypto[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
DEPEND="
|
||||
${RDEPEND}
|
||||
test? (
|
||||
dev-python/nose[${PYTHON_USEDEP}]
|
||||
dev-python/flake8[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
|
||||
src_prepare() {
|
||||
eapply "${FILESDIR}/nrk.patch"
|
||||
eapply_user
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
distutils-r1_src_compile
|
||||
|
||||
emake ${PN}.{bash-completion,fish,zsh}
|
||||
}
|
||||
|
||||
python_test() {
|
||||
emake offlinetest
|
||||
}
|
||||
|
||||
python_install_all() {
|
||||
dodoc README.md
|
||||
|
||||
newbashcomp ${PN}.bash-completion ${PN}
|
||||
|
||||
insinto /usr/share/zsh/site-functions
|
||||
newins ${PN}.zsh _${PN}
|
||||
|
||||
insinto /usr/share/fish/vendor_completions.d
|
||||
doins ${PN}.fish
|
||||
|
||||
distutils-r1_python_install_all
|
||||
|
||||
rm -r "${ED}"/usr/etc || die
|
||||
rm -r "${ED}"/usr/share/doc/youtube_dl || die
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
|
||||
elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
|
||||
elog
|
||||
elog "${PN} works fine on its own on most sites. However, if you want"
|
||||
elog "to convert video/audio, you'll need avconf (media-video/libav) or"
|
||||
elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
|
||||
elog "videos can be retrieved in a higher quality format without sound."
|
||||
elog "${PN} will detect whether avconv/ffmpeg is present and"
|
||||
elog "automatically pick the best option."
|
||||
elog
|
||||
elog "Videos or video formats streamed via RTMP protocol can only be"
|
||||
elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
|
||||
elog
|
||||
elog "Downloading MMS and RTSP videos requires either mplayer"
|
||||
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
|
||||
elog
|
||||
elog "If you want ${PN} to embed thumbnails from the metadata into the"
|
||||
elog "resulting MP4 files, consider installing media-video/atomicparsley"
|
||||
}
|
Loading…
Reference in a new issue