net-misc/rpki-client: New release 6.8p0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
This commit is contained in:
parent
bdacea3c9f
commit
68f8102787
|
@ -1,3 +1,4 @@
|
|||
DIST rpki-client-6.6_p2.tar.gz 42840 BLAKE2B f5075376925cad57893a27c463c6727362e108cbccb348785ca4940fbaa8262286342ecb6f5fa59a0615009bc16571b15218483822c827528ecc19e1963c9e6b SHA512 5acdabef9b0373fb2fe47a2b9cb2638809ac1260b273c1566e3dbd34287c3703dd7979a7ba98b7d5b305664add6f2d5af4564ad2315033406e5e835f1051951f
|
||||
DIST rpki-client-6.7_p0.tar.gz 44454 BLAKE2B 2336f3a8f4a0cb53a9c6f4df6dbd269ff1e8bcb11b61d4c283c3153e563054efb163339ec7852f45e12cc7e9544522d7dabc62d0f79b5a6951014e47980caad9 SHA512 018e237a4075779850f18bdc69c49dac03d8bb2d377dbd680f1faa307057647ea3188acb6b78766e6563dd48afadd5eaea419413c41a018882d1a8b147bb6630
|
||||
DIST rpki-client-6.7_p1.tar.gz 44463 BLAKE2B c269a502c680a4c41c2201fceed2f3bab7b83e3a6a173fea5081ced073e10f02fd7aaa07ef4b9d14f816c88871ffee8c65126f0efcda9e8ca7c08032cac179d6 SHA512 bc9815ab6cd930715e9494b82b1547a419706db3fa4eca003767d6e39c3a63c0a3f3048c211c773e1f0e87043b0bfd622b0d5be856ccced27f893eefc9511211
|
||||
DIST rpki-client-6.8_p0.tar.gz 47429 BLAKE2B 8823484ae9a9e11ce10c39a0e846b7a5e70b4f8a395a965f6031be81b3ef6fbc0dfaee5a99779081a1cd9a8a2bccd8060c9966bfc7d4e14907fe33ac09b552dc SHA512 3bbba6dff5d6ef6e21bf3889943c8a9b2c82bc1a6d589c8f29e967f613d78f747610d4ed38c40a19b21146db9e9487e39e6f8522830ce4c1a6d6ee8434178ae2
|
||||
|
|
25
net-misc/rpki-client/files/rpki-client-6.8-update.patch
Normal file
25
net-misc/rpki-client/files/rpki-client-6.8-update.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- a/update.sh 2020-05-19 20:27:54.816143493 +0200
|
||||
+++ b/update.sh 2020-05-19 20:28:03.700182804 +0200
|
||||
@@ -4,22 +4,6 @@
|
||||
openbsd_branch=`cat OPENBSD_BRANCH`
|
||||
openbgpd_version=`cat VERSION`
|
||||
|
||||
-# pull in latest upstream code
|
||||
-echo "pulling upstream openbsd source"
|
||||
-if [ ! -d openbsd ]; then
|
||||
- if [ -z "${RPKICLIENT_GIT}" ]; then
|
||||
- git clone https://github.com/rpki-client/rpki-client-openbsd.git openbsd
|
||||
- else
|
||||
- git clone "${RPKICLIENT_GIT}/openbsd"
|
||||
- fi
|
||||
-fi
|
||||
-if [ -d openbsd/.git ]; then
|
||||
- (cd openbsd/src
|
||||
- git fetch
|
||||
- git checkout "${openbsd_branch}"
|
||||
- git pull --rebase)
|
||||
-fi
|
||||
-
|
||||
# setup source paths
|
||||
dir=`pwd`
|
||||
patches="${dir}/patches"
|
68
net-misc/rpki-client/rpki-client-6.8_p0.ebuild
Normal file
68
net-misc/rpki-client/rpki-client-6.8_p0.ebuild
Normal file
|
@ -0,0 +1,68 @@
|
|||
# Copyright 2020 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit autotools git-r3
|
||||
|
||||
MY_PN="${PN}-portable"
|
||||
MY_PV="${PV/_p/p}"
|
||||
MY_P="${MY_PN}-${MY_PV}"
|
||||
|
||||
DESCRIPTION="Portability shim for OpenBSD's rpki-client"
|
||||
HOMEPAGE="https://rpki-client.org/"
|
||||
SRC_URI="https://github.com/${PN}/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
|
||||
EGIT_REPO_URI="https://github.com/${PN}/${PN}-openbsd.git"
|
||||
|
||||
LICENSE="ISC"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
DEPEND="
|
||||
acct-group/_rpki-client
|
||||
acct-user/_rpki-client
|
||||
"
|
||||
RDEPEND="${DEPEND}"
|
||||
BDEPEND=""
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-${PV%_*}-update.patch"
|
||||
)
|
||||
|
||||
S="${WORKDIR}/${MY_P}"
|
||||
|
||||
src_unpack() {
|
||||
default
|
||||
|
||||
EGIT_BRANCH=$(cat "${S}"/OPENBSD_BRANCH)
|
||||
EGIT_CHECKOUT_DIR="${S}/openbsd"
|
||||
git-r3_fetch
|
||||
git-r3_checkout
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
|
||||
cd "${S}"
|
||||
./autogen.sh
|
||||
|
||||
eautoreconf
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local myeconfargs=(
|
||||
--with-rsync=rsync
|
||||
--with-base-dir="/var/cache/${PN}"
|
||||
--with-output-dir="/var/db/${PN}"
|
||||
)
|
||||
econf "${myeconfargs[@]}"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
emake DESTDIR="${D}" BINDIR="/usr/bin" MANDIR="/usr/share/man" install
|
||||
insinto /etc/rpki
|
||||
doins *.tal
|
||||
keepdir "/var/db/${PN}/"
|
||||
fowners -R _rpki-client "/var/db/${PN}/"
|
||||
}
|
Loading…
Reference in a new issue