rpki-client from OpenBSD
This commit is contained in:
parent
e757b65662
commit
4036252caf
3
net-misc/rpki-client/Manifest
Normal file
3
net-misc/rpki-client/Manifest
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
AUX rpki-client-0.2.0-Makefile.patch 596 BLAKE2B 0d8062597885df95ee543536c2a1093fe0b89d86c72d99174cbc7421ac9593b7e2625dca8dd120aee34e54e4e367537ed85d6779065b55832c7a66f3c1cfcc96 SHA512 67214f1522eea7b597287881ab8b110e4e774b0cc83f68fc388a86e7bc394b778a3b5814e302adc5f74862f8fc60953ccf3b7a6e14dbc0e5f7e402cff9af86cf
|
||||||
|
DIST rpki-client-0.2.0.tar.gz 68985 BLAKE2B 1e70df7a8e7194d37a6120dbeb141a2c1cddcb2348070b9a1a3176180fda3044d0da32b37916165c12dc25d55aec349bd059e76701235933b8a4014c4e73b202 SHA512 16eba850a39e7312c33718b15b4a520da13872e46bb3339039eff947feaabf5ad698d604be062b535b9ff50135dd07a2c06ebf0f04491960634649b11e493e55
|
||||||
|
EBUILD rpki-client-0.2.0.ebuild 900 BLAKE2B 0c96fc7dec503ce6583452a121eb7dcb11c921e1778fc576c3da2aba8f88c86e7dec97c3030f4c5a9fbaf4241450a0d64d575fb4dcf6aad8c5d58d2967f62d12 SHA512 f96680f7c2bed206e951b8d717036f9b1ed1655a2633e78a657926351ec504a14306b2b45c2efc1e284af5c685db537a70b157ac437b3bf6bfceef2c4bc1d3d3
|
19
net-misc/rpki-client/files/rpki-client-0.2.0-Makefile.patch
Normal file
19
net-misc/rpki-client/files/rpki-client-0.2.0-Makefile.patch
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
--- Makefile 2019-06-16 16:32:45.000000000 +0200
|
||||||
|
+++ Makefile 2019-12-07 17:14:01.888076319 +0100
|
||||||
|
@@ -30,12 +30,12 @@
|
||||||
|
test-tal
|
||||||
|
|
||||||
|
# Linux.
|
||||||
|
-#LDADD += `pkg-config --libs openssl` -lresolv
|
||||||
|
-#CFLAGS += `pkg-config --cflags openssl`
|
||||||
|
+LDADD += `pkg-config --libs openssl` -lresolv
|
||||||
|
+CFLAGS += `pkg-config --cflags openssl`
|
||||||
|
|
||||||
|
# OpenBSD.
|
||||||
|
-CFLAGS += -I/usr/local/include/eopenssl
|
||||||
|
-LDADD += /usr/local/lib/eopenssl/libssl.a /usr/local/lib/eopenssl/libcrypto.a
|
||||||
|
+#CFLAGS += -I/usr/local/include/eopenssl
|
||||||
|
+#LDADD += /usr/local/lib/eopenssl/libssl.a /usr/local/lib/eopenssl/libcrypto.a
|
||||||
|
|
||||||
|
all: $(BINS)
|
||||||
|
|
41
net-misc/rpki-client/rpki-client-0.2.0.ebuild
Normal file
41
net-misc/rpki-client/rpki-client-0.2.0.ebuild
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
# Copyright 2019 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
inherit eutils user
|
||||||
|
|
||||||
|
DESCRIPTION="RPKI client implementation"
|
||||||
|
HOMEPAGE="https://github.com/kristapsdz/rpki-client"
|
||||||
|
#SRC_URI="https://github.com/kristapsdz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
|
SRC_URI="https://github.com/kristapsdz/${PN}/archive/VERSION_0_2_0.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="ISC"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
IUSE=""
|
||||||
|
|
||||||
|
DEPEND=""
|
||||||
|
RDEPEND="${DEPEND}"
|
||||||
|
BDEPEND=""
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
./configure CPPFLAGS="`pkg-config --cflags openssl`" \
|
||||||
|
LDFLAGS="`pkg-config --libs-only-L openssl`"
|
||||||
|
}
|
||||||
|
|
||||||
|
src_unpack() {
|
||||||
|
unpack ${A}
|
||||||
|
mv ${WORKDIR}/${PN}-VERSION_0_2_0 ${S}
|
||||||
|
cd "${S}"
|
||||||
|
eapply -p0 "${FILESDIR}/${P}-Makefile.patch"
|
||||||
|
}
|
||||||
|
|
||||||
|
pkg_setup() {
|
||||||
|
enewgroup _rpki-client
|
||||||
|
enewuser _rpki-client
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
emake DESTDIR="${D}" BINDIR="/usr/bin" MANDIR="/usr/share/man" install
|
||||||
|
}
|
Loading…
Reference in a new issue