net-voip/linphone-desktop: New package from nest
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr
This commit is contained in:
parent
7070a4c54c
commit
30525fbd2a
1
net-voip/linphone-desktop/Manifest
Normal file
1
net-voip/linphone-desktop/Manifest
Normal file
|
@ -0,0 +1 @@
|
|||
DIST linphone-desktop-4.3.2.tar.gz 2675071 BLAKE2B 33a88a45a0c52592d762b4bd1a5e7b6dc4b474d2d434e566dc4a6efceaec7cb63404013ebe7beb05b5b4350d6c6e3ce21391bceb4777afd9b1aa0b02b35e6f28 SHA512 c095596a5a8004ea62221b983ceca6371dfc1d81e0c97e6bbba77b42876173ba273027f3b2f47c443b225538ece44813c82d53aa7a0d181e621cda7e4afcaac6
|
|
@ -0,0 +1,26 @@
|
|||
diff --git a/linphone-app/src/app/cli/Cli.cpp b/linphone-app/src/app/cli/Cli.cpp
|
||||
index 3d84ad63dbb149da63de73ebdabd5cbf35b0a113..9193f3d4887a913d9be3ba5bcb4c6d130841f6d8 100644
|
||||
--- a/linphone-app/src/app/cli/Cli.cpp
|
||||
+++ b/linphone-app/src/app/cli/Cli.cpp
|
||||
@@ -182,7 +182,7 @@ static void cliInitiateConference (QHash<QString, QString> &args) {
|
||||
|
||||
qInfo() << QStringLiteral("Create conference with id: `%1`.").arg(id);
|
||||
auto confParameters = core->createConferenceParams();
|
||||
- confParameters->setVideoEnabled(false);// Video is not yet fully supported by the application in conference
|
||||
+ confParameters->enableVideo(false);// Video is not yet fully supported by the application in conference
|
||||
conference = core->createConferenceWithParams(confParameters);
|
||||
conference->setId(Utils::appStringToCoreString(id));
|
||||
|
||||
diff --git a/linphone-app/src/components/conference/ConferenceAddModel.cpp b/linphone-app/src/components/conference/ConferenceAddModel.cpp
|
||||
index 5087be272527bb2bcf4a83f392f10da1efeede9a..b67bb71341eb22be268d438e4b818edc19f7081d 100644
|
||||
--- a/linphone-app/src/components/conference/ConferenceAddModel.cpp
|
||||
+++ b/linphone-app/src/components/conference/ConferenceAddModel.cpp
|
||||
@@ -149,7 +149,7 @@ void ConferenceHelperModel::ConferenceAddModel::update () {
|
||||
shared_ptr<linphone::Conference> conference = mConferenceHelperModel->mCore->getConference();
|
||||
if(!conference){
|
||||
auto parameters = mConferenceHelperModel->mCore->createConferenceParams();
|
||||
- parameters->setVideoEnabled(false);// Video is not yet fully supported by the application in conference
|
||||
+ parameters->enableVideo(false);// Video is not yet fully supported by the application in conference
|
||||
conference = mConferenceHelperModel->mCore->createConferenceWithParams(parameters);
|
||||
}
|
||||
auto currentCalls = CoreManager::getInstance()->getCore()->getCalls();
|
83
net-voip/linphone-desktop/linphone-desktop-4.3.2.ebuild
Normal file
83
net-voip/linphone-desktop/linphone-desktop-4.3.2.ebuild
Normal file
|
@ -0,0 +1,83 @@
|
|||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
inherit cmake xdg
|
||||
|
||||
DESCRIPTION="A free VoIP and video softphone based on the SIP protocol"
|
||||
HOMEPAGE="https://gitlab.linphone.org/BC/public/linphone-desktop"
|
||||
SRC_URI="https://gitlab.linphone.org/BC/public/${PN}/-/archive/${PV}/${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-3"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
SLOT="0"
|
||||
RESTRICT="test" # needs sdk
|
||||
|
||||
RDEPEND="dev-libs/belcard
|
||||
dev-libs/jsoncpp:0=
|
||||
dev-libs/liblinphone
|
||||
dev-qt/qtconcurrent:5
|
||||
dev-qt/qtcore:5
|
||||
dev-qt/qtdbus:5
|
||||
dev-qt/qtgui:5
|
||||
dev-qt/qtnetwork:5
|
||||
dev-qt/qtquickcontrols:5
|
||||
dev-qt/qtquickcontrols2:5[widgets]
|
||||
dev-qt/qtsvg:5
|
||||
dev-qt/qtwidgets:5
|
||||
media-libs/mediastreamer2[zrtp,jpeg]
|
||||
net-libs/bctoolbox
|
||||
net-libs/ortp"
|
||||
DEPEND="${RDEPEND}"
|
||||
BDEPEND="dev-vcs/git
|
||||
dev-qt/linguist-tools:5
|
||||
virtual/pkgconfig"
|
||||
|
||||
PATCHES=( "${FILESDIR}"/"${P}"-update-sdk.patch )
|
||||
|
||||
DOCS=( {CHANGELOG,README}.md )
|
||||
|
||||
src_prepare() {
|
||||
# bc_git_version needs git repository
|
||||
pushd linphone-app || die "pushd failed"
|
||||
git init > /dev/null || die "git init failed"
|
||||
git config user.email "${PN}@gentoo.org" || die "git config failed"
|
||||
git config user.name "${PN}" || die "git config failed"
|
||||
git add --all > /dev/null || die "git add failed"
|
||||
git commit -m "${PV}" > /dev/null || die "git commit failed"
|
||||
git tag -m "${PV}" "${PV}" || die "git tag failed"
|
||||
popd || die "popd failed"
|
||||
|
||||
# Don't build SDK and app-library targets, remove non-existed directory,
|
||||
# reuse OUTPUT for bin directory, remove RPATH and create directories under share directory
|
||||
sed -i -e "/ExternalProject_Add(sdk/,+17d" \
|
||||
-e "/app-library/d" \
|
||||
-e '/set(LINPHONE_OUTPUT_DIR/s|/linphone-sdk/desktop||' \
|
||||
-e "/set(APPLICATION_OUTPUT_DIR/s|/OUTPUT|/bin|" \
|
||||
-e "/ORIGIN/d" \
|
||||
-e "\$aadd_custom_target(make-linphone ALL COMMAND \${CMAKE_COMMAND} -E make_directory \"\${CMAKE_BINARY_DIR}/share/linphone\")" \
|
||||
-e "\$aadd_custom_target(make-sounds ALL COMMAND \${CMAKE_COMMAND} -E make_directory \"\${CMAKE_BINARY_DIR}/share/sounds/linphone\")" \
|
||||
CMakeLists.txt || die "sed failed for CMakeLists.txt"
|
||||
# Don't install qt.conf
|
||||
sed -i "/install(FILES \"\${CMAKE_CURRENT_BINARY_DIR}\/..\/..\/qt.conf/d" \
|
||||
linphone-app/cmake_builder/linphone_package/CMakeLists.txt \
|
||||
|| die "sed failed for linphone_package/CMakeLists.txt"
|
||||
# Don't install anything in compile phase and fix headers installation
|
||||
sed -i -e '/-E copy $<TARGET/d' \
|
||||
-e '/-E copy_directory/d' \
|
||||
-e '/-E make_directory/d' \
|
||||
-e '/install(DIRECTORY/s|\.|${CMAKE_INSTALL_PREFIX}|' \
|
||||
linphone-app/CMakeLists.txt || die "sed failed for linphone-app/CMakeLists.txt"
|
||||
|
||||
cmake_src_prepare
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local mycmakeargs=(
|
||||
-DENABLE_APP_PACKAGING=NO
|
||||
-DENABLE_BUILD_VERBOSE=YES
|
||||
-DENABLE_UPDATE_CHECK=NO
|
||||
)
|
||||
cmake_src_configure
|
||||
}
|
20
net-voip/linphone-desktop/metadata.xml
Normal file
20
net-voip/linphone-desktop/metadata.xml
Normal file
|
@ -0,0 +1,20 @@
|
|||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>spiderx@spiderx.dp.ua</email>
|
||||
<name>Vladimir Pavljuchenkov</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>proxy-maint@gentoo.org</email>
|
||||
<name>Proxy Maintainers</name>
|
||||
</maintainer>
|
||||
<longdescription lang="en">
|
||||
An open source SIP phone for voice/video calls and instant messaging,
|
||||
and is available for mobile and desktop environments
|
||||
(iOS, Android, GNU/Linux, macOS, Windows).
|
||||
</longdescription>
|
||||
<upstream>
|
||||
<remote-id type="github">BelledonneCommunications/linphone-deskop</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
Reference in a new issue